Client cannot connect to server after re-installing (v1.7.0004 and earlier) |
 |
Problem
Experian Payments Gateway client cannot connect to the server because the Secure Socket Layer Certificates have expired.
Cause
For versions before 1.7.0007, the SSL certificates expired on 31/12/2009. Therefore if you have re-installed your server or client with any of these early versions you will have installed the expired certificates.
Resolution
To continue using Experian Payments Gateway you must update the SSL certificates on all of your re-installed machines.
Download the SSL certificates hot fix and follow the instructions included to update the certificates.
The updated SSL certificates are valid until 31/12/2014.
Download for Windows
Download for non-Windows
Additional information
1. Do I need to apply the hotfix to all of my client machines?
You must install this hot fix on any machine that you have reinstalled. This includes the server and any clients machines that cannot connect to the server to process payments once the hot fix has been applied to the server.
2. When do the new certificates expire?The certificates shipped with the SSL hot fix (and Experian Payments Gateway versions 1.7.0007 and above) are valid from May 11, 2009 until December 31, 2014.
3. Where should I apply the new certificate files?
Copy the new certificate files to the Experian Payments Gateway installation folder.
For the server:
The default location for Windows installations is C:\Program Files\Experian Payments\Experian Payments Gateway Server (or C:\Program Files\Eiger Systems\EigerPAY Gateway Server for versions before 1.6).
The default location for Unix and other non-Windows server installations is /eiger/EigerPAY_Gateway (on the iSeries platform, this is in the IFS).
For the client, the default location is C:\Program Files\Experian Payments\Experian Payments Gateway (or C:\Program Files\Eiger Systems\EigerPAY Gateway for versions before 1.6).
4. How do I know whether the SSL certificates have been renewed?
To check whether a server or client machine has been updated, open each of the four certificate files in a text editor, such as Notepad, and search for "Experian Payments". If found, you are using the new files. The old certificates contain "Eiger Systems Limited".
5. What do I need to do if I use Java Web Start?
Contact the Experian Payments Support team to request a special build of the Web Start certificates. This process can take a number of weeks so you should request the build at your earliest opportunity.
You will be sent an epg_res.jar file. Copy this to your Web Start lib folder, replacing the existing file. You must also apply the SSL hotfix to your server in the normal way.
6. How do I know whether I'm using Java Web Start?
If you deploy your clients by navigating to an internal Web page and clicking a link, you are using Java Web Start.
If you install your clients by running setup.exe from a CD-ROM or shared network drive, you do not use Java Web Start.
7. Which versions of Experian Payments Gateway include the updated SSL certificates?
Experian Payments Gateway 1.7.0007 and higher includes the updated certificates.
You need to apply this hot fix if you re-installed earlier versions of Experian Payments Gateway (previously EigerPAY Gateway).
Applies to
Rate this article